auto route delay

  • Hi,

    I'm running conquest dicom server(latest version) and forwarding image to another conquest server and it works perfectly. But all i need to know is how can i edit dicom.ini file for starting auto route process after 20 seconds after incoming images to my server completely. For now it works simultaneously and it slows down my server very much.


  • In the exportconverter or importconverter you should be able to do: sleep(20000) forward to aetitle

    I believe this should wait 20 seconds before sending the images

    Or you can do: forward study to aetitle

    that way Conquest will wait for the whole study to arrive before forwarding it, preventing simultaneous receiving and sending operations

  • Hi,

    I still have issue with the automatic forwarding. It appears that sometimes the studies are not forwarded, especially if they come very close to one another (if we send an exam now and one in 20 seconds or so, none of them get forwarded or only one goes). The destination server is a Caresteam one - does this have a connection?

    Below is my configuration of the forwarder:

    #Virtual server options

    ForwardAssociationLevel = STUDY

    ForwardAssociationRefreshDelay = 3600

    ExportConverters = 1

    ExportConverter0 = forward study to <pacsAEtitle> after 10

    VirtualServerFor0 = <pacsAEtitle>,CACHESTUDIES

    Later edit: I saw my "not forwarded" studies in the file DelayedFetchForwardFailures6104 . I attach it.

    Thank you!

  • Hello,

    The only log I could find is PacsTrouble.log and I attach the last section of it (the same kind of messages repeat throughout the file). Those "Failed to Listen () - bind error" messages appear all the time, even when it works.

    Thank you!

  • I attach the entire log file (let me know if there is another log you need), the DICOM.ini file and the file (I only modified the DICOM.ini file and the AETitle through the web service interface). Let me know if you need other files as well.

    Thank you for your help!

  • All right,

    I think your service manager keeps stopping and restarting dgate causing it to lose its internal status. Somehow it thinks the server is down while it isn't, it may be "pinging" it resulting in "***Failed to Listen () - bind error". Which service script are you using?


  • Hi,

    I'm not sure what you mean by service manager - it is run in Ubuntu (we start it with this command: systemctl start app-dgate.service). I tried running dgate from the command line and I get this :

    ./dgate -v

    DGATE (1.5.0c, build Thu May 5 12:07:53 2022, bits 64) is running as threaded server

    Database type: built-in SQLite driver

    Starting 1 DelayedForwarderThreads

    Started 1 export queue thread(s)

    ***Failed to Listen () - bind error

  • OK, so it appears an instance of dgate (or its service) started in the background and then the service manager was trying to start it again (that error appears if you try to start dgate when it's already running - even when I try to start it manually). Now I killed it from the running tasks, it started on its own and it appears to work fine now.

    Thank you very much for your assistance!

  • Hi,

    Is there a limitation that the conquest service cannot store and send data at the same time? I noticed that for some examinations it keeps retrying to send them if they were interrupted by an incoming exam - see the attached portion of the log (it kept retrying to send the patient received at 09:31:23 - in the log I attach) all day, intermittently forwarding other patients (but not all of them were forwarded)...

    Thank you!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!