Error Writing File

  • Hello,

    Thanks for any assistance in advance.

    I'm using Conquest Server 1.4.17. Never had an issue until today for years. (I use two of them actually for redundancy, different locations, both with the same issue.) I attached the log file from today.

    The error I receive is Error Writing File...and then the MRN#, etc. I checked all the permissions and they are all fine, nothing changed. I just find it odd that this happened.

    Would anyone know what the problem could be?

    Thank You very much for any assistance.

  • Hi,

    I would expect this to be a permissions issue. An automatic update? You may need to relax safety on remote login. If conquest runs as a service, maybe modify the service user to yourself. The check is an independent read of the file after it is written.


  • Marcel,

    Thank you so much for the reply. All that was done was an update to the Synology DS1813+. Both NAS's were affected by it. So that leads me to believe that's what caused it. They told me nothing they can do because they can write a file manually to the NAS's and pointed me back to ConQuest. (They aren't helpful at all.) I have it setup to run as Local User and not a service. Remote login is only me via Logmein. I have Conquest to run on startup is all.

    I checked all permissions about 100x, seems as if all is correct. Conquest just won't write to the NAS and unable to pull anything back. You can query but Conquest reports "unable to find MRN-....etc, etc.

    I thought of reinstalling but afraid to. Can I install the newest version on top of the current? I'm not sure of the process to do so. Same directory, run it this time as NT service? I truly cannot lose 4TB worth of data on both.

    Thanks again for any assistance Marcel!

    I just noticed something interesting. When I try to Query/Move to any date, I get "Unable to Connect." To me it seems as if the Conquest doesn't see the NAS. That's really odd. I did check the dicom.ini file and it's pointing correctly. This is also my backup NAS. I'm running re-initialization on the backup.

    On the Main NAS, I can Query/Move and view the studies done on that date. (ex: 20180831 Study/Study Root) I still get the same error,

    I'm at a loss, I don't where else to turn to get this working again on either of them. Still says, Error writing file /destination and the dicom information.

  • Marcel...Just fixed the main one. Changed port 5678 to 104....boom it worked.

    Crazy, I checked that port first thing, firewall wasn't blocking it either.

    The backup is still running the re initialization database so I'll change that to port 104 when complete.

    Just wanted to update!


  • Marcel,

    I think I may have spoke too soon. The images are being saved to C:\ and I'm unable to pull back any studies from remote locations. I can Query/Move and view them within Conquest though. Would you mind looking at the Dicom.ini file I attached? It's the same one I've been using all along.

    Also, when you query the Conquest, it'll find the patient/study but it won't send and delete the study! The exact mention is this:

    Deleting database entry for image....

    ***missing file: MAG1 MRN-45469\....

    Thanks so much for any assistance. This has be so confused now.

  • Hi Marcel,

    Yes, I can access the files on the NAS, I can even write to it manually. (Right Click, create folder, etc.) When idle, ConQuest tries to write the files from C: to the NAS but same error, Error Writing \\diskstation\archive\dbase\images\ So at night I've been turning off Conquest service, and manually moving them to the NAS. To pull back I've been copying them to a local PC and then importing them into KPACS and then send to PACS server.

    The backup is much worse, I still can't receive any studies since that one writes directly to the NAS for some reason, but it was always setup that way. (I Attached that file on the backup Conquest.) Been doing the same as above, turning off CQ, copy/paste into NAS.

    Would you have any ideas on how to correct this? It only happened when the NAS's firmware was updated and Synology tells me that it's an issue with the CQ and the permissions are correct on the NAS. (I checked as well, I cannot see anything abnormal and I didn't change anything.)

    Thanks as always!

  • Hi Marcel,

    Well, I just got it to work sort of. I used my laptop as a test on Wednesday, it worked and it's still running. (Not as a Service, but this isn't long term) Since then...

    Short story today: I installed new SSD drive on the workstation, reinstalled W7, no updates, still didn't work. Uninstalled as a Service what you mentioned and it started working. Logged off, tried another send, Error Writing File to \\Diskstation\......

    I installed Service, reboot. Didn't work. Uninstalled Service, reboot. Working again. I'm Re-initializing the database on the Workstation over the weekend so they can retrieve images again. But if I logoff or reboot, it won't work again. (Rinse/Repeat it seems since I figured this out)

    Why would it do that? I'm so confused as why suddenly it started doing this after four years. Sorry for the edits.

    Thanks for any suggestions.

  • Hi everyone.

    I had same or similar problem with windows 10 and cq server. Uptill few weeks ago i use conquest and kpacs storing us and xray pictures on my NAS - without any problem since few years !

    Thank you Marcel. Great work and support.

    I have 15000 series , its about 150 k jpg's . Not very much but enough for my small office. I changed my workstation from win8.1 to windows 10 . Nothing more works as intended. I considered changing to other Pacs system but nobody in my office wanted other software. In cq log i saw problem with finding files and writing on MAG0 ( which is NAS in my case )

    After changing logon for services ( as upon stated) it works again ! Great!:thumbup:


Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!