Wrong storage using dgate --movestudies and custom FileNameSyntax

  • Hi Marcel,

    While using "dgate --movestudies" between 2 servers (on 150c) with a custom FileNameSyntax on the destination server, I'm questionning why I do have such wrong behavior while transferring different images:

    Thu Dec 15 08:33:23 2022 Rewritten file: /home/z/images/empty/empt/y//undefined_0000_000000_1670541699b283.dcm

    Thu Dec 15 08:33:25 2022 Rewritten file: /home/z/images/empty/empt/y//undefined_0000_000000_1670541699b283.dcm

    Thu Dec 15 08:33:27 2022 Rewritten file: /home/z/images/empty/empt/y//undefined_0000_000000_1670541699b283.dcm

    Thu Dec 15 08:33:28 2022 Rewritten file: /home/z/images/empty/empt/y//undefined_0000_000000_1670541699b283.dcm


    instead of

    Thu Dec 15 08:33:22 2022 Written file: /home/z/images/DX/2022/12/13/

    dicom.ini setting:

    FileNameSyntax = %modality%/%studydate[0,3]/%studydate[4,5]/%studydate[6,7]/%seriesuid_%series_%image_%time%counter.dcm

    This does not occur on all files ??!! but hopefully a regular C-store transfer works fine

    As a result many different images are saved into the same unique file, it smells bad...

    Any idea how to fix this ?

    Best regards

  • Hi,

    dgate --movestudies initiates a regular C-MOVE. It appears that the image that is transferred there is corrupted somehow, all its dicom tags are empty - and the filename generated reflects that. Can you see/share what it stores? What OS and database are you using?


  • The image on the destination server looks fine, at least the last overwritten file is a regular dicom file with tags and valid pixel data, so strange

    I'm on Linux with mariadb, I forgot to say j4 compressions is used

  • Hi,

    is it possible the empty filenames were stored in the database before somehow? Conquest will reuse earlier generates filenames unless instructed not to do so with:

    RenameOnRewrite = 1


  • Just tried, yes it works now as expected ! Congrats ! I was not aware of this setting...
    Don't know what was wrong, I sent a bunch of 15.000 images that failed somewhere I believe

    Thank you very much Marcel

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!