Version 1.5.0.d Protocol error 0 in PDU:Read From GE OEC 9800

  • We have a GE OEC 9800 that crashes every time it sends or verifies (memory error) to the Conquest dicom 1.5.0.d.. We get the following from the debug level 4 "Protocol error 0 in PDU:Read" can we change the PDU size or do you have any ideas what the fix is ?? ..



  • Hi Shaun,

    The other user stopped responding so I forgot all about it.

    It is interesting that older versions of conquest show no issue.

    Would you be willing to test older versions? Then we can pinpoint the change (after 2010) that started this behavior.


  • Hi,

    this is a 32 bits version of dgate.exe that allows setting PDUSize from dicom.ini. To test it add e.g.

    PDUSize = 4096

    below TCPPort in dicom.ini. You can run it by backup up and renaming dgate64.exe and copy files from install32 into a test server.


  • Absolutely, Happy to work with and test.. I will be at that site tomorrow (Thursday 20th) and will test the 32 bit file for you..

    FYI I have added my direct phone number to my profile and I have Viber installed so you can reach me directly if you want..



  • Marcel,

    So I renamed the dgate64 to dgate64backup and then copied the install32 folder files into the dicomserver.. I copied the "dgate" file you sent me and copied that into the dicomserver folder as well, then I added the PDUSize =32000 into the dicom.ini file (under the TCPPort line). I then started the conquest server and have it set to debug at level 4.

    I then tried sending a test image and it now does not crash with a memory error but it instead just sits at the "copy in progress" section frozen.

    The debug on the conquest just sees the initial connection and also stays at the same point. Example below..

    [CONQUESTSRV1PC] set debug level 4 from GUI

    [CONQUESTSRV1PC] set debug log from GUI

    [CONQUESTSRV1PC] Connected by address: fe0ca8c0

    It looks like its not reading the Application Context correctly (maybe)?? The other guy who had the same issues had the following on the SBS Server that was working:

    Application Context : "1.2.840.10008.", PDU length: 32000

    Presentation Context 0 "1.2.840.10008.1.1" 1


    I have set the PDU length to 32000 , I have the "LittleEndianImplicit 1.2.840.10008.1.2 transfer" and the "DICOM 1.2.840.10008. application" uncommented in the dgatesop file..

    Any other ideas?? Any chance we could talk directly to brainstorm this??



  • Marcel,

    Just got back to the site today and set the dicom.ini PDUSize to 4096 and it just locked up again.. The only thing I can think to test is the Old version 1.4.16 and try it on the 2019 server and an Old 2008 Server version and see if the issues is in the OS file security/permissions??

    So can I have a link to a 1.4.16 copy of conquest please??

    I was also going to try the new and old versions on linux..

    What are your thoughts??


  • Marcel,

    Just tried it again and got the following.. and the GE OEC locked up with memory errors and crashed..

    Debug log (level 4)

    [CONQUESTSRV1PC] Connected by address: fe0ca8c0

    [CONQUESTSRV1PC] Invalid message in PDU:Multiplex

    [CONQUESTSRV1PC] ***AppContext Not-Supported

    [CONQUESTSRV1PC] no transfer syntax could be negotiated

    [CONQUESTSRV1PC] *** multiplex: connection terminated

    [CONQUESTSRV1PC] Connected by address: fe0ca8c0

    [CONQUESTSRV1PC] Testing transfer: '1.2.840.10008.1.2' against list #0 = '1.2.840.10008.1.2'


Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!