Update 1.4.19d1 released

  • Dear users.

    Due to some persistent issues with DICOM communication (what a simple PDU size change can lead to!) this is a small update to 1.4.19d, called 1.4.19d. The only change is that the number of bytes transmitted has been reduced by 6. Now the DCMTK utilities such as DCMGETSCU work again with Conquest.

    You can download the release here:


    Can you please try it? Reporting of issues will be greatly appreciated.

    As usual you can update by extracting dgate.exe or dgate64.exe and conquestdicomserver.exe, but also quite a few other files have changed - mainly in the web interface, lua code and installer.

    Part of the source code is included, the full source code of the next release (1.5.0) can now be browsed on: https://github.com/marcelvanherk/Conquest-DICOM-Server

    A fix in transfer syntax and pdu length can can be downloaded here:



  • Hi,

    First of all thankyou for the wonderful software and support. much appreciated.

    I have tested the 1.1.19d1 and the previous issue of fetching data on workstations is resolved. I have found another one, if the debug is enabled and if a dicom send is performed from the browse database tab, the data is sent but the conquest server hangs and goes into not responding gui.


  • Hi,

    I tried installing and selected the option Native MySQL Driver. MySQL installed is version "MySQL Community Server 8.0.15". I did the manual database creation by hand in MySQL. This was confirmed OK as when I press "Make MySQL Database" this message came up


    ------------------- End data source update or creation --------------------

    [CONQUESTSRV1] Create Database: conquest, user: root, password: <not_shown_here>

    [CONQUESTSRV1] ***Failed MYSQLExec : CREATE DATABASE conquest

    [CONQUESTSRV1] ***Error: Can't create database 'conquest'; database exists

    [CONQUESTSRV1] ----------------------------------

  • I have to break down my response as long reply keeps giving me an error. Continue here ..

    When I pressed Verify Database Installation I get no errors. However when I press re-initialize database I get an sql syntax error when creating DICOMImages table.

  • [CONQUESTSRV1] ***Failed MYSQLExec : CREATE TABLE DICOMImages (SOPInstanc varchar(64) PRIMARY KEY not null, SOPClassUI varchar(64), ImageNumbe varchar(12), ImageDate char(8) , ImageTime varchar(16), EchoNumber varchar(64), NumberOfFr varchar(12), AcqDate char(8) , AcqTime varchar(16), ReceivingC varchar(16), AcqNumber varchar(12), SliceLocat varchar(16), SamplesPer varchar(5), PhotoMetri varchar(16), Rows varchar(5), Colums varchar(5), BitsStored varchar(5), ImageType varchar(128), ImageID varchar(16), ImagePat varchar(64), SeriesInst varchar(64), AccessTime int, qTimeStamp int, qFlags int, qSpare varchar(64), ObjectFile varchar(255), DeviceName varchar(32))%3

  • Hi,

    apparantly you can no longer use Rows and Columns as field names on later mysql versions. I suggest to change these to e.g. QRows and QColumns. This is done in dicom.sql. Then you can regenerate.



  • goedemiddag,
    Ik las met vreugde over de 6 bytes van de nieuwe release d1.
    ik worstel al jaren met de PDU size als ik DICOM beelden naar OSIRIX wil sturen.
    Er komt altijd de foutmelding: illegal PDU length 16390, max expected 16384.
    Dat zijn precies 6 bytes teveel.
    Maar helaas, versie 1419d1 meerdere keren geinstalleerd maar dezelfde foutmelding blijft

    komen op mn macbook (daar draait OSIRIX op, bij mij thuis)
    En bovenin Conquest blijft 1419c1 staan.

    Doe ik toch iets verkeerd of klopt het zip pakket van 1419d1 niet helemaal?
    Op mijn werken gebruiken we CONQUEST al jaren en vind het een toppertje!
    Zeer robuust, stabiel en eenvoudig te configureren.
    En en daarbij made in 010, geweldig

  • correctie, correctie,

    nogmaals een goede middag

    Ik heb Conquest helemaal van mijn laptop afgedelete en toen

    een maagdelijke Conquest 1419d1 geinstalleerd en met goed resultaat!
    Eindelijk, na jaren verdriet accepteert OSIRIX beelden van CONQUEST.
    bovenin Conquest staat nog wel het vorige versie nummer maardat is een detail
    Geweldige bugfix!!

  • sorry, sorry

    I just saw that the language in this forum is English.
    summary of the my posts

    version 1419d1 solved my long lasting problem: OSIRIX on my Macbook could not receive

    images from Conquest because PDU size too large (6 bytes)
    And this is fixed now. PDU size of Conquest was 16390 and is now 16384
    Conquest is a fantastic, robust, stable and easy to configure DICOM server
    And made in Holland

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!