DICOM server 1.4.19b bug fixes and updates

  • Hi Conquest users,

    Here is update 1.4.19b. It adds printer header/footer/background; gamma clause in bitmap converters;
    fix cancel C-move crash; and provides several other fixes.

    For Linux users there is a new web based installer - please try it as follows , after installing the required tools such as compilers and apache:

    cd install
    chmod 777 linux.sh

    You can download the release here:


    Can you please try it? Reporting of issues will be greatly appreciated. As usual you can update as well by extracting dgate.exe or dgate64.exe and conquestdicomserver.exe, but also quite a few other files have changed - mainly in the web interface.


  • Here bug reports for 1.4.19b will be collected.

    These are leftover bugs:
    1) add LittleEndianExplicit to GUI connecting to dgate. Futured
    2) Improve safety of sqlite by regular flushing. Futured, but users can change SqLite startup pragma for safer operation in 1.4.19c
    3) Check these changes: 20140608 mvh Added BYTE PCid to CStoreRSP::Write; This change is under review: pcid does not seem to get the right value
    4) brainix sample data fails to load from zip; maybe because of French folder names
    5) sql server and access database ODBC install only work for 32 bits of dgate (e.g. disable 64 bits or create ODBC entry by hand)
    6) install second server when service of first runs gives trouble - do an echo on the install button and fail if found - futured
    7 ) last line of dicom.ini does not read if no CR (IndexDBF = 50) - futured
    8 ) Publish about Docker release of Lance
    9) GUI fails to run as user after install as service on server2012; does run as admin - futured
    10) Implement web interface for batch anonymisation - futured
    11) overlapvirtualget=0 breaks the virtual server operation (hardw) - futured
    12) Thumbnail in MR confuses kpacs viewer (Dennis on mail) - futured
    13) wish: OperatorConsole.printf ("*** multiplex: connection terminated [%s]\n", CallingApTitle); Futured
    14) color print server does not work. - futured, awaiting more information.
    15) Forward compressed as j2(?) does not set transfer syntax UID correctly in transmitted image. This is an issue on dcm4che but has not been seen in conquest to conquest transmission.
    16) browse tab does not work if user of server service and server gui are differerent.

    New bugs:

    17) Missing " on end of dicom.sql file when generated with web install (minor issue). In 1.4.19c
    18 ) min() in qrsop.cxx must be replaced by math.min() to compile 1.4.19b under linux. Fix is here: qrsop.zip. In 1.4.19c
    19) Add option to force case insensitive queries (for postgres etc), e.g. UPPER(PatientNam) LIKE 'AA*'. In 1.4.19c columns can be made DT_ISTR in dicom.sql
    20) Distribute new ODBC documentation (in 1.4.19c)
    21) Fix link to forum on html page. Done
    22) fix wordwrap plugin in zbs config (add ide: to getEditor()). In 1.4.19c
    23) Distribute conquest_auto.lua and update mobdebug.lua to 0.702. In 1.4.19c
    24) Make preretrieve/forward hangup error retry configurable line 10875. RetryForwardRemoteDICOMError added in 1.4.19c
    25) Enable 'binary' and up/download modes of servercommand. In 1.4.19c
    26) anonymize_script.lua needs modification for linux: \\ -> / http://forum.image-systems.biz/viewtopic.php?f=33&t=48690. In 1.4.19c

    27) Increase buffersize as reported by LPloeger. In 1.4.19c.
    28 ) enpq proposed change to delay after last image in 'process by after' mechanism (done in 1.4.19c) and reported random failure (not confirmed)

    29) Implement C-GET. Is there in 1.4.19c!
    30) The latest postgres no longer allows unencrypted passwords. Double check install code.
    31) Added ladle based webserver in 1.4.19c
    32) Add fix to Linux script shown in post below. In 1.4.19c
    33) Make max PDU size configurable. Futured.
    34) Search in header is limited to 1 M characters (lsp), extended to 100MB in 1.4.19c

    35) Add SqLiteStartup parameter to allow changing PRAGMA synchroneous=OFF. In 1.4.19c

    36) Bomberbug posted jpeg compressed US image 12345.zip that decompresses to green hue. Unfortunately not yet fixed due to lack of time. Futured.
    37) zooming from the wado viewer crashes server when running from Ladle. In 1.4.19c

    38 ) web based web server config does not update existing files. In 1.4.19c

    39) request for time stamp in ms. Futured.

    40) when conquest runs from web install controller, anonymize and zip fails. Fixed in 1.4.19c

    41) add lua dicomget function. Futured

    42) validate that case insensitive query also matches lower case input. Futured

    43) fix typo in code completion file conquest.lua. In 1.4.19c

    44) The strange colors in RGB images like celikel 1.zip is a signed/unsigned char bug new gamma code. Fixed in 1.4.19c

    45) fix min() compilation error on new linux systems in aaac.cxx and aarq.cxx - use MIN(). In 1.4.19c

    46) update linux manual for newer systems, make missing. In 1.4.19c

    47) the web installer will not start dgate (with dicom.ini) installed with maklinux due to use of relative paths in the config. Maybe add reconfig button. Futured.

    48 ) removed the subfolder 'distribution' from zip file. In 1.4.19c

    49) fixed defaults of ImportExportDragAndDrop and MAGDeviceThreshHold. In 1.4.19c

    50) When opening a zip from web interface running on apache, the filename is not set correctly; it is when running from Ladle. Futured

    51) Add luasocket to linux dgate. In 1.4.19c

    52) Added webserver.sh for minimal viewer using Ladle on Linux. In 1.4.19c

    53) Ladle must use / and \ appropriately. In 1.4.19c

    54) wado.lua must be WADO.lua. In 1.4.19c

    55) use BaseDir on dgate to find all folders (now many use current folder). Futured.

  • Hi Marcel,

    Has Bug #15 been corrected in the latest release of 1.4.19b ?

  • Hi,

    I do not think so, I had insufficient information to track it down. I need to a full debug log from the conquest side, its config and how conquest is is instructed to send compressed to see what happens. If I try conquest to conquest everything works fine.


  • Dear Marcel,
    I tried installing DICOM server 1.4.19b on Ubuntu Server 16.04.04, but showed an error: did not found dgatesmall. It looks like the file is not in the zip.
    Before i forget, I had trouble starting Conquest automatically with the system with the Linux manual guidelines.
    I looked for the cause of the problem and noticed that the script to start Conquest need the following lines on the top:



    Wtih this I put the script (conquest.sh) in the folder /etc/init.d, gave the command: chmod +x /etc/init.d/conquest.sh and chmod 755 /etc/init.d/conquest.sh, and after that: update-rc.d conquest.sh defaults.
    Now, Conquest started to boot with the system.
    Hope this helps.

  • Thanks,

    dgatesmall is a special build for the web based install that is made on the fly. If you can run the web based install script again in a console I would be curious what the error is. There is one bug fix in a source in the post though.

    Thanks for the fix in the script. I will implement it.


  • Is it supposed to use UTF in the tags of DICOM files so that, for example, the names of folders are correctly created when data is received. I use the name of the patient to create the folder and, as applied to the Russian language, the folder's corruption consists of incorrect characters ...

  • Hi,

    I never got around to implement this. We should be able to script this change as experiment. If you let me know exactly which DICOM tags need to be set, read or changed it should be doable using Lua in dicom.ini. Conquest does not touch any of the tags, but the database collation is never set and will be default.



  • I meant that when encoding, for example, a patient name in UTF and with an encoding tag set also as UTF when using in dicom.ini the order of creating a folder of such a patient under set 11 - the Russian name of the patient in the folder name is displayed incorrectly, although in the program name is written correctly. It turns out that the Russian characters are decoded correctly, but the folder with the Russian name is a set of some incorrect characters ... Can you fix this?

    I wrote my little program that translates Russian characters from the incorrect IR-144 table into UTF - because initially Conquest does not understand the IR-144 (by the way, many programs do not understand this particular encoding with the Cyrillic alphabet). I solved one problem - now the Cyrillic is displayed correctly in the program itself, however the folder with this name consists of invalid characters ... So the problem is when creating the folder? Does some procedure for forming a folder name work incorrectly with UTF encoding?

  • Hi,

    special characters that are invalid in a filename are suppressed as follows:

    I guess this messes up UTF.


  • Marcel
    On a fresh install of CentOS 7.4 I'm attempting to compile dgate with the maklinux script. I'm currently receiving the following error on compile.

    In file included from ./src/dgate/src/total.cpp:116:0:./src/dgate/dicomlib/qrsop.cxx: In member function ‘BOOL StandardRetrieve::Read(PDU_Service*, DICOMCommandObject*)’:./src/dgate/dicomlib/qrsop.cxx:314:53: error: ‘min’ was not declared in this scope 0xff00, min(ADDO.GetSize() - Index - 1, 65535),

    resolved by adding

    #define min(a, b) ((a)<(b)?(a):(b))

    to the beginning of ./src/dgate/dicomlib/qrsop.cxx

    also from the jpeg-6c configure (run from maklinux)
    on Centos 7.4

    /usr/bin/install -c -m 644 ./cjpeg.1 /usr/local/man/man1/cjpeg.1

    should be

    /usr/bin/install -c -m 644 ./cjpeg.1 /usr/local/share/man/man1/cjpeg.1

    I know the above is more distro specific but possibly adding a call to manpath in the configure script might resolve the issue more permanently.

    Mr Johnathan Bravo

  • Hello Marcel.

    Is 1.4.19c available for dowload? I have and failed to install either using the web install or the traditional install, and I see from other posts that you have fixed the issues in 1.4.19c but I can't see a link to download...

    Thanks :-)

  • Some feedback on the web installer:

    • When I unzippped the original download, a base folder named distribution was created which I hadn't expected.
    • Within distribution/install there is no file called install.sh - there is a file called linux.sh
    • When I run that file, firefox opens (not my default browser) but fails to load the page.
    • nohup.out contains the following:
    Dictionary file ./..\dgate.dic is missing, some server functions will not work correctly
    *** Not enough rights to write in MAG0
    ***Error loading kfactor file:./..\dicom.sql
    DGATE (1.4.19b, build Fri May 25 08:42:10 2018, bits 64) is running as threaded server
    Database type: NULL driver (black hole)
    *** File dgate.dic is missing, some server functions will not work correctly

    This was tested after I replaced distribution/src/dgate/dicomlib/qrsop.cxx

    I haven't yet looked at what linux.sh is doing to see where it goes wrong.

  • Thanks. Made that change.


    *** Not enough rights to write in MAG0
    ***Error loading acr-nema map file:./acrnema.map
    DGATE (1.4.19b, build Fri May 25 18:14:16 2018, bits 64) is running as threaded server
    Database type: NULL driver (black hole)


    $ ./linux.sh
    [sudo] password for mcdonaghe:
    5912/tcp: 24067
    nohup: appending output to 'nohup.out'
    ###!!! [Parent][MessageChannel] Error: (msgtype=0x15007F,name=PBrowser::Msg_Destroy) Closed channel: cannot send/recv

    Last line after I closed Firefox, which failed to load again.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!