DICOM server 1.4.19 released

  • Tonight, at last, version 1.4.19 of the conquest DICOM server has been released.

    You can find it here: https://ingenium.home.xs4all.nl/dicom.html

    I would like to thank all users for feedback and error reports. Please keep on doing this to allow improving the quality of the software.

    The latest updates include: A complete recoding of the browser in the GUI for speed and lots of new options such as flexible DICOM modification, server speedup, JpegLS and better Jpeg2000 compression (thanks Bruce Barton), a completely scripted web interface with a new interactive viewer, and options for a new flexible anonymisation server.


  • Here bug reports for 1.4.19 will be collected.

    These are leftover bugs:
    1) add LittleEndianExplicit to GUI connecting to dgate. Futured
    2) Improve safety of sqlite by regular flushing. Futured
    3) Check these changes: 20140608 mvh Added BYTE PCid to CStoreRSP::Write; This change is under review: pcid does not seem to get the right value
    4) brainix sample data fails to load from zip; maybe because of French folder names
    5) sql server and access database ODBC install only work for 32 bits of dgate (e.g. disable 64 bits or create ODBC entry by hand)
    6) Autoinstall newweb - this is in the web based installer in 1.4.17a
    7) install second server when service of first runs gives trouble - do an echo on the install button and fail if found - futured
    8 ) last line of dicom.ini does not read if no CR (IndexDBF = 50) - futured
    9) Publish about Docker release of Lance
    10) gui freeze on window 10 - not reproduced so far
    11) GUI fails to run as user after install as service on server2012; does run as admin - futured
    12) Implement wadoviewerhelp - futured
    13) Implement web interface for batch anonymisation - futured
    14) overlapvirtualget=0 breaks the virtual server operation (hardw) - futured
    15) Zoom disabled for wadoviewers for version 1.4.19 < 1.4.19b (4 files) - in 1.4.19a
    16) Thumbnail in MR confuses kpacs viewer (Dennis on mail) - futured
    17) weasis starter has hardcoded, must be %serveraddress%
    18) wish: OperatorConsole.printf ("*** multiplex: connection terminated [%s]\n", CallingApTitle);
    19) c-move response cannot convey >65536 images, should max numbers at 65535 - futured

    20) I updated about 12h after first release to properly use charls1.x; please use release file dated 9 February. In 1.4.19a
    21) After Linux install, cgi-bin subfolders such as newweb have insufficient access rights. Fix with sudo chmod 777 /usr/lib/cgi-bin/newweb and same for viewers folder. In 1.4.19a
    22) Fixes needed to MySQL Linux documentation. Use sudu apt-get install libmysql++-dev instead of libmysql-client-dev; mysql --user=root --password=xxx, see below. In 1.4.19a
    23) Fixes needed to MySQL Linux build (maklinux). Add $SRC/ before jpeg-6c in in line 29 (2 times, see below). In 1.4.19a
    24) newweb interface displays lua error when UIDMods does not yet exist (in line return #a, suggest to change to #(a or {})). Does not affect operation. In 1.4.19a
    25) for anypage to block default web interface, also set defaultpage
    26) default install causes some issues. Use manual install. - futured
    27) color print server does not work. - futured, awaiting more information.
    28 ) 1.4.19 does not seem to run on Windows XP; special XP compile with MS100 seems unstable. Need to debug it.
    29) servercommand may need larger bufferspace for return data for future service web page. In 1.4.19a
    30) Move result and merged_row out of HAVE_LIBJPEG to ToJPGStrip to allow compile without jpeg-6c. In 1.4.19a
    31) remove typedef INT32 in jpeg_encoder.cpp. In 1.4.19a
    32) There is no Lua call for servercommand to console, needed for generating large web items (e.g. zip); suggest extra par '', 'cgibinary', 'cgihtml', filename. In 1.4.19a
    33) lua servercommand cannot return binary data as HTML processing Is enabled by default. In 1.4.19a
    34) dicommove documentation is incorrect, if 4th parameter is passed 1 means patientroot move, else studyroot; In 1.4.19a
    35) merge series button is broken in GUI; request to add merge studies button. In 1.4.19a
    36) Modifystudy seems to have a problem (not reproduced)
    37) Lossless jpeg compressed color US image decompressed green (lost 2014 fix). In 1.4.19a

    Please report all problems as this will improve future releases. Thanks!


  • I just tested the 1.4.19 release with MySQL on Linux and found some flaws. Here is what to do.

    install g++ and apache etc as per linuxmanual


    sudo apt-get install mysql-server
    (set and remember root password, here for example: as_set_above)
    sudo apt-get install mysql-client
    sudo apt-get install libmysql++-dev
    gedit maklinux
    on line 29, add $SRC/ before jpeg-6c (2 times)
    save it

    run ./maklinux option 1
    mysql --user=root --password=as_set_above
    create database conquest;
    edit dicom.ini to set Password = as_set_above

    ./dgate -v -r

    Now everything runs!


  • Hello, I have a trouble with installation.
    I'm unzip archive into folder "C:\dicomserver" and lunch "ConquestDICOMServer.exe"
    With Default installation - have a message about error (in attachment)...
    Then I try to start dgate.exe - have a message - "Access denied"

    With version 1.4.17 - all OK.

    I tried to delete folder, change PORT, change NAME - error again...

    tried on WinXP 32bit RUS and WinXP 64bit ENG.

  • Hi,

    apparantly default install pushes the 'create data source' button even when it is disabled (such as for sqlite). That may cause the error. After the error, dgate64 or conquestdicomserver may still run in the background, blocking access. Try again with normal install.


  • Ok. I tried to install server on my home PC (WIN_7 32 bit RUS) (with manual install with defaul built in SQL) - it's all OK...
    Tomorrow I will try again with my Work PC with XP. May be some problems with OS configuration...

  • Hi,

    Thanks for the report. I have not tried on XP for a while, develop on 7, test on 8 and 10 and Linux. My best bet would be to combine conquestdicomserver.exe from the last 1.4.17 with the dgate(64).exe from 1.4.19. This should run fine and offer all features of the new server (not the GUI though).



  • Hi,
    I try to install 1.4.17 version and replace from x.x.19 ConquestDICOMServer.exe and dgate.exe in differenet combinations (only dgate, only server, both)....
    No results - same ERROR.

    I think that problem in both files - ConquestDICOMServer.exe and dgate.exe ...

    So, Win XP is not supported in new version?

  • May be it 's possible to compile project with some* option compatible with "old" Win Xp ?
    I'm thinking about migration on Win-7, but my server works on Win XP 64bit and other Workstation in Ethernet also works on Win XP 64bit, so it is comfortable to have same operating system on different mashines...
    P.S. My server works with Workstations VITREA, which uses specific C-Move command (only special version with E, founded on this forum - version of 1.4.17e helps me to work with VITREA).
    Version 1.4.19 works normally with VITREA ? I don't check it yet :-)

  • Hi,

    The issue is in dgate(64).exe due to the VS2015 compiler. I can compile for XP using an older compiler (MS100) and a few changes, but is does not seem to run reliably. I attached the 2 exe's for you to test.



    • 1419xp.7z

      (1.91 MB, downloaded 434 times, last: )

    Marcel van Herk is developer of the Conquest DICOM server together with Lambert Zijp.

  • Hi,
    I check new files - all works :-)
    Later I will replace my 1.4.17 version by x.19 with this fix.

    Now, I found a new problem:
    If I send a patien with ID (for example 1841) from CT and then change (on CT) some patient data (I change surname: from "ANDREEVA V.N." to "ANDREEVA A.A.") , send data again and.....
    took a new error message in LOG and ERROR on CT queue...
    Decision - delete patient on Conquest and CT send normally new data.

    In normal, in my opinion, Conquest soft must replace old data with new. - but it doesn't occur...
    Can I fix it?

    [CONQUESTSRV1] ***Refused to enter inconsistent link SeriesInst into DICOMImages: PatientID = '1841' SOPInstanc = '1.2.392.200036.9116.' AND ImagePat = '1841', Old='1.2.392.200036.9116.', Refused='1.2.392.200036.9116.'
    16.02.2017 15:02:06 [CONQUESTSRV1] ***Error saving to SQL: 1841\1.2.392.200036.9116.
    16.02.2017 15:02:49 closing the server

  • Hi,

    you can write a script to delete the data on such occurence, but you would need to delete the whole series. But conquest has no better option than what it does now, see post "why not chnage patientID of anm image". By the way, changing name only would not get a refusal. It is due to changing the patientID.

    Have a look at RejectedImageConverter0 in the manual and command 'retry', e g.,

    RejectedImageConverter0 = newuids; retry



  • Yep. But it may delete too much, be careful and try it out on an empty testserver first. You add these lines to dicom.ini. It may not work at all (untested).

    RejectedImageConverter0 = delete study; retry

    you can also experiment with delete series or delete image. I have a feeling though the delete command may be broken.

    Or try (lua equivalent, more likely to work), add at bottom of dicom.ini

    RejectedImageConverter0 = x=DicomObject(); x.SeriesInstanceUID = Data.SeriesInstanceUID; dicomdelete(x); script('retry')

    be careful!


Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!